This project is read-only.

NuGet Install issue.

Feb 12, 2012 at 9:12 PM

Getting this error when trying to install via NuGet. Yet on the NuGet catalog page its says it has no dependencies.

 

Install-Package : Could not install package 'YLAD 1.4'. You are trying to install this package into a project that targets
 'Silverlight,Version=v4.0,Profile=WindowsPhone', but the package does not contain any assembly references that are compatible
 with that framework. For more information, contact the package author.
At line:1 char:16
+ install-package <<<<  YLAD
    + CategoryInfo          : NotSpecified: (:) [Install-Package], InvalidOperationException
    + FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PowerShell.Commands.InstallPackageCommand
Feb 13, 2012 at 7:32 AM
Edited Feb 13, 2012 at 7:33 AM

Hi Nick. This is not a dependency issue. You're trying to target "WindowsPhone" which is the identifier for the RTM release of the tools. YLAD only supports Windows Phone 7.1 ("Mango") which is identified by "WindowsPhone71". Apparently your installed SDK is out of date, or your project targets the old system version. Please upgrade to the 7.1/7.5 release of the phone tools, or change the target of your project to Windows Phone 7.1.

Feb 14, 2012 at 1:41 PM
That took care of the problem. Weird cause I thought I already had 7.1 installed.

On 2/13/2012 1:33 AM, Mister_Goodcat wrote:

From: Mister_Goodcat

Hi Nick. This is not a dependency issue. You're trying to target "WindowsPhone" which is the identifier for the RTM release of the tools. YLAD only supports Windows Phone 7.1 ("Mango") which is identified by "WindowsPhone71". Apparently your installed SDK is out of date. Please upgrade to the 7.1/7.5 release of the phone tools.

Apr 26, 2012 at 10:00 PM

I receive this error message:

Attempting to resolve dependency 'CommonServiceLocator (≥ 1.0)'.
Successfully installed 'CommonServiceLocator 1.0'.
Successfully installed 'Unity 2.1.505.0'.
Successfully uninstalled 'CommonServiceLocator 1.0'.
Install failed. Rolling back...
Could not install package 'CommonServiceLocator 1.0'. You are trying to install this package into a project that targets 'Silverlight,Version=v4.0,Profile=WindowsPhone71', but the package does not contain any assembly references that are compatible with that framework. For more information, contact the package author.

I have install the 7.1 and 7.1.1 update of the WP tools. The target of the project is 7.1 !!!!

Apr 27, 2012 at 5:17 AM

@Mythox: I don't know what package you were trying to install, but it wasn't YLAD. YLAD has no dependencies, and it installs fine on 7.1.1. The package you're trying to install requires CommonServiceLocator, which is a .NET project not suitable for Windows Phone.